Flarum v1.3.0 袋熊 发布

随着 v1.2 于今年早些时候推出,我们在对开发人员的工作方式进行了几次调整后迅速跟进 v1.3。有了这些,我们就可以为您带来我们的最新版本。

对于开发者


所有与 Flarum 1.2 兼容的扩展都应该适用于 1.3。我们已经完成了所有的打字和打字稿组件,因此这些应该更容易在您自己的代码中使用。可以在升级指南中找到针对开发人员的所有更改的完整列表。

升级


在升级之前,请确保为您的public/assets目录、您composer.json的数据库和您的数据库创建一个备份!

在开始升级过程之前,请确保您在 Admin Dashboard 中使用 Flarum 1.0.0 或更高版本,或者输入php flarum info. 如果不是,请使用以前的发行说明从早期版本升级。

要从 Flarum 版本 1 升级到 1.3 版本,请查看我们的升级指南文档。由于缺少重大更改,与以前的主要版本升级相比,该过程应该容易得多。

如果您遇到任何问题,请在支持标签下打开一个新讨论。忽略类似的讨论,无论如何打开一个新的。确保充分提及 、 和任何错误的输出 。php flarum infocomposer why-not flarum/core v1.3.0

一些额外的想法:

  • 如果您正在运行队列(redis、数据库等),请确保重新启动它们。
  • 如果您打算使用此新版本(或未来版本)升级您的 PHP 版本。先更新 php 然后运行composer update --prefer-dist -a --no-dev​​. Composer 然后将安装适合您的新 php 版本的依赖项。
  • 大多数与 v1.2 兼容的扩展都将与 v1.3 兼容。

升级有问题?确保在支持标签下打开讨论。忽略类似的讨论,无论如何打开一个新的。确保充分提及 、 和任何错误的php flarum info输出composer why-not flarum/core v1.3.0。在此处发布可能会使您的问题得到更慢的解决。

 

留下评论